Turn on TLS 1.2 to View this Page

Security changes require you to update your web browser(s)

To secure data on websites and combat the threat of hackers who try to steal account information, some of the security methods used to protect data are no longer recommended.

On Tuesday, May 1, 2018 we'll be upgrading our website to use only the latest TLS 1.2 security

  • Visitors using out-of-date browsers will need to upgrade their browsers to continue to access otpco.com, ePay, and Home Energy Analyzer.
  • If your Internet browser is out of date, update it now to the most current version available.

How do I update my Internet browser?

While we’re unable to provide technical support to configure customer-owned computer systems, here's a helpful website where you can easily upgrade the most commonly used browsers to the latest version.

  1. Click on the link above, then choose the browser you wish to update. From there you’ll see a Download button or link.
  2. Click to start the download and agree to allow any prompts during the installation. 

Tip: Most browsers are free to download. If you’re concerned that updating your current browser may create compatibility issues with other sites you use, you could install a second browser to use with ePay.

Which Internet browser do I have?

Most browsers have an About link in their Help menus. Select the link to display the name of the browser and the version you’re using. The most common Internet browsers include:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Chrome
  • Opera
  • Safari
  • Android (mobile)

I already have an upgraded Internet browser. What should I do?

If after our security change is complete you have an issue:

  • Verify that TLS 1.2 is enabled in the security settings section of your Internet browser.
  • Contact your Internet Service Provider’s customer support to learn about upgrading your browser and to verify the security settings that are in place.
Search